Style:    Language:

Author Topic: I Can't install new Patch 3.19. Please help me  (Read 721 times)

0 Members and 1 Guest are viewing this topic.

Yoda

  • Guest
I Can't install new Patch 3.19. Please help me
« on: June 15, 2009, 09:43:24 AM »
Hi all,
i have installed the CIV IV Beyond the sword (i have origninal CIV 4 and original BTS but buyed on line, everything running on windows vista home premium).
Once i entered in the lobby i have been asked to download and install the new 3.19 patch. I lounched it and after the legal accept i push ok install : program start and after about 10 sec the process crash ( " PATCH 3.19 do not respond").
I tried  several times , reinstalled both Civilization but without succeed.
Can some one help me please?
Many Thanks

Offline lilhammer

  • Settler
  • Posts: 12
Re: I Can't install new Patch 3.19. Please help me
« Reply #1 on: June 16, 2009, 02:27:31 AM »
U need to download patch from where u bought games such as direct to drive.  ;D

 

League