Style:    Language:

Author Topic: Need help...  (Read 531 times)

0 Members and 1 Guest are viewing this topic.

Offline Isra

  • Settler
  • Posts: 1
Need help...
« on: September 11, 2014, 10:53:10 AM »
Hi Civers,

Didn`t play for 2 years. Today installed civ4 bts, patch 3.19.

Trying to login with my old login or create new gamespyid account - I receive - The login attempt has failed.

What have changed since 2012?

Offline CanuckSoldier

  • Owner/Global Admin/Operator
  • Global Admin
  • Commando
  • ******
  • Posts: 6743
  • Gender: Male
    • Civilization Players Leagues
Re: Need help...
« Reply #1 on: September 12, 2014, 05:43:15 AM »
Gamespy was closed by Glu Inc this year sadly.  2K moved Civ4 to steam, but sadly there is a bug were only 4 players can play in the Steam version.  Also to compound that issue, many players don't own the steam version or can prove they bought civ4.  So most games have moved to Skype chats, and because even direct IP tries to phone home to GS, we often use the Evolve VPN system to run the game as a LAN game.

Yes there is a lot of jumping around to get a game now, but there are still lots of games happening.

PM me in skype and I will add you to the skype chats and the regular players can certainly bring you up to speed.

CS
Owner/Global Admin/Operator
Civilization Players Leagues
www.civplayers.com

 

League